Story:
=====
The basic idea of this lab was to create a frame relay network using EIGRP. We have three routers R1, R2 and R3 connected to a frame relay switch. R1 is the hub.
I felt that the lab will be easy but I am going wrong somewhere. I created the frame relay network and configured EIGRP over it and I am able to ping one spoke router from another spoke router. But then I created loopbacks on R2 and advertised them using EIGRP but R1 is not learning those addresses.
Config:
On R1:
======
!
interface Serial0/0
ip address 10.10.10.10 255.255.255.0
encapsulation frame-relay
no ip split-horizon eigrp 1
clock rate 2000000
frame-relay map ip 10.10.10.10 101
frame-relay map ip 10.10.10.30 101 broadcast
frame-relay map ip 10.10.10.20 102 broadcast
no frame-relay inverse-arp
end
!
R1#sh run | sec eigrp
no ip split-horizon eigrp 1
router eigrp 1
network 0.0.0.0
no auto-summary
R1#
On R2:
======
!
interface Serial0/0
ip address 10.10.10.20 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 10.10.10.20 203
frame-relay map ip 10.10.10.30 203
frame-relay map ip 10.10.10.10 203
no frame-relay inverse-arp
end
!
R2#sh run | sec eigrp
router eigrp 1
network 0.0.0.0
no auto-summary
R2#
On R3:
======
!
interface Serial0/0
ip address 10.10.10.30 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 10.10.10.30 202
frame-relay map ip 10.10.10.20 202
frame-relay map ip 10.10.10.10 202
no frame-relay inverse-arp
end
!
R3#sh run | sec eigrp
router eigrp 1
network 0.0.0.0
no auto-summary
R3#
Found the solution!!!
ReplyDeleteI did nt use broadcast command on R2 and R3 frame relasy config. Since eigrp adv are multicast addresses you need to enable pseudo broadcast to convert the multicast packets to unicast..
Config on R2 and R3 now:
=======================
On R2:
!
interface Serial0/0
ip address 10.10.10.20 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 10.10.10.20 203
frame-relay map ip 10.10.10.30 203 broadcast
frame-relay map ip 10.10.10.10 203 broadcast
no frame-relay inverse-arp
end
!
On R3:
!
interface Serial0/0
ip address 10.10.10.30 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 10.10.10.30 202
frame-relay map ip 10.10.10.20 202 broadcast
frame-relay map ip 10.10.10.10 202 broadcast
no frame-relay inverse-arp
end
!
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
20.0.0.0/32 is subnetted, 3 subnets
D 20.20.20.20 [90/2809856] via 10.10.10.10, 00:00:59, Serial0/0
D 20.20.20.21 [90/2809856] via 10.10.10.10, 00:00:59, Serial0/0
D 20.20.20.22 [90/2809856] via 10.10.10.10, 00:00:59, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Serial0/0
R3#ping 20.20.20.20
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.20.20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/20/64 ms